Pontiac G6 Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1 (Edited)
Hi, I have talked to may different Tech's about this problem, its an 08 G6 Basic. I was moving down to Texas about a month ago and my car died (left the car on all night). So I got a jump from someone and he hooked the cables up wrong, Positive to negative and negative to positive. anyways got it started and when I was driving the radio, onstar and the wipers did'nt work anymore. I checked all of the fuses, and disconnected the wiper motor and tested the plug and it was not getting power. So I again checked all of the fuses and they were all good. I dont know what else could be wrong? Please if you know or think you know anything please ket me know. And Thnaks if you can help.
 

·
Registered
Joined
·
2,388 Posts
Hi, I have talked to may different Tech's about this problem, its an 08 G6 Basic. I was moving down to Texas about a month ago and my car died (left the car on all night). So I got a jump from someone and he hooked the cables up wrong, Positive to negative and negative to positive. anyways got it started and when I was driving the radio, onstar and the wipers did'nt work anymore. I checked all of the fuses, and disconnected the wiper motor and tested the plug and it was not getting power. So I again checked all of the fuses and they were all good. I dont know what else could be wrong? Please if you know or think you know anything please ket me know. And Thnaks if you can help.
Onstar plays through the radio so if the radio is dead you won't hear onstar audio. Are you saying the onstar button won't light up now (which I suppose means no power to the onstar module)?

The wipers are on a separate circuit so that would not be related to the radio issue. The wiper switch is fused separately from the wiper motor so I assume you checked the switch fuse in the cabin fuse box. Also, there are two wiper relays that you can swap out to verify they are still good.

Have you checked for 12v into the radio?

All cars have reverse polarity protection built in but not all protection schemes are equal. In other words, it's possible you fried the radio.

http://www.g6ownersclub.com/forum/attachment.php?attachmentid=2392&stc=1&d=1314916579
 

Attachments

·
Registered
Joined
·
10 Posts
Discussion Starter #4
for greenman

Hi green man. Thanks for the in put. Ok let me answer your questions now. Yes the on star is lighted. It is the car phone that doesn't work actually. Also no I do not have the right tool to check the breaker's or what ever the big fuses are called. I was going to try and do that next. Also yes I have checked the fuses in the cabin. And no I have not checked the actual radio fuse, I was trying to figure out how to take the radio out to do that. So hopefilly this helps you more with my question. Please let me kow what else you may think. I dont really care about the radio, I just want the wipera to work, but the radio working would be a bonus. Thanks again
 

·
Registered
Joined
·
2,388 Posts
Yes the on star is lighted. It is the car phone that doesn't work actually. Also no I do not have the right tool to check the breaker's or what ever the big fuses are called. I was going to try and do that next. Also yes I have checked the fuses in the cabin. And no I have not checked the actual radio fuse, I was trying to figure out how to take the radio out to do that. So hopefilly this helps you more with my question. Please let me kow what else you may think. I dont really care about the radio, I just want the wipera to work, but the radio working would be a bonus. Thanks again
So to focus on the wipers:

If you can read it, that schematic tells you everything you need to know about the wiper circuit. The fuse & relay numbers & locations are there as well.

For the two wiper relays, if either one is bad you will have no wipers. Although I doubt you destroyed one, it's remotely possible. You don't need to test them. Just swap them one at a time with another relay in the box with the same numbers on top. There are several that are identical. I suggest you mark relay 39 & 49 first & then swap them one at a time with a relay that is known good & then see if the wipers light up after each swap. Note the relays have a notch in the top & need to go back in with the notch in the same position. It is too easy to install 4 pin relays backwards.

You might take a picture or two of the fuse box before doing anything just to be sure things get put back correctly. I doubt that you've done any serious damage to the wiper circuit.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Ok I will definatly try that. I want to do everything I can do before I have to rake it to a dealer. Can i get the relay's at auto zone or where ever or are they a dealer only? And thanks again. I really appreciate your help and input. After I figure out the wipers then I will work on the radio. Thanks again and I will let you know if that was the problem.
 

·
Registered
Joined
·
422 Posts
For the radio, do a computer reset by disconnecting your battery for 30 mins. Its happened a few times to me where the radio just seems to have died after needing a jump start, and that has always gotten it to work again.
 

·
Registered
Joined
·
2,388 Posts
Can i get the relay's at auto zone or where ever or are they a dealer only?
You can get them at any auto parts store much cheaper then at a dealer but I really recommend doing the swapping first to see if they are bad & save yourself the money if they aren't.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
Born 2 ski. I did do the computer reset I unhooked the battery for 1hour and I still got nothing. I'm thinking my radio is gone? I would pull the radio out and check the fuse but im not sure how to get the radio out? I uses to work for a dodge dealer and did the radio pulls and put in's but his is different. So not sure if you have any input that would be great. And greenman I am going to try swaying them before I just didn't know if you could get them at a parts store or not. Thanks to the both of you again. I will let you both know what if any progress I may have. And if you can think of anything else please let me know. Thanks again
 

·
Registered
Joined
·
2,388 Posts
I would pull the radio out and check the fuse but im not sure how to get the radio out?
The only fuse for the radio is in the cabin fuse box so if that's good the radio is probably a paperweight. But then again, it only takes five seconds to verify that 12v is actually reaching the fuse. It's possible the problem is upstream.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #13
Radio fixed, still no wipers

Ok, so I got the radio to work. It ended up being the 10 amp fuse in the cabin fuse box. One side tested ok and the other did not. So problem fixed, the radio and onstar came back. But actually I thought the onstar was completly out, but it was only the car phone portion. But anyways the wipers. I tried changing out the relay's for the wipers and that was a no go. So I also took apart the steering column and unpluged the connector to the wipers and im not getting power there also. So any other advice? So to recap, the fuses and relay's are good. The connector that plugs into the wiper motor is not getting power, and the control switch on the steering column is not getting power either. So if anyone else or the same people can help out or narrow it down that would be great. and again I appreciate everyone's help. Thanks
 

·
Registered
Joined
·
10 Posts
Discussion Starter #14
one more thing when I checked the cabin fuses there was a fuse for the wiper something like wiper sw???? I dont ever remember there being a fuse there, should I put one in and see what happens?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #17
So should Iput a fuse in to that spot then. Sorry electrical is def not my strong suit. I couldnt wire anything even if you showed me 100 times.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #19
ok thanks, I know that was prob a stupid question but i had to ask. I will try it and see what happens. Thanks again
 
1 - 19 of 19 Posts
Top