Pontiac G6 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Won't start.....No Fuel Pressure

2007 G6 3.5

Started this past weekend while driving, it would just die, but could be restarted. Then yesterday it would not restart after it died. Now it wont start at all and no fuel pressure.

Checked fuse and swapped relay with no change.

Verified power to the connector that goes to the fuel pump, I have a constant and two key on power wires. I forgot to check the ground before I pulled the gas tank but will do that next.

After the tank was out I decided to check to see if putting 12v to the pump would turn it on and yes it started to squirt fuel, but in the car I did not have any pressure at the valve on the fuel line under the hood.

Is the fuel pump controlled by another means like crank sensor?
 

·
Lifetime Member
Joined
·
3,269 Posts
WOW! It could be several things but I couldn't be of much help w/o a wiring schematic.
When you turn the key "on" (from the off position) the fuel pump should run just for a second or two, did you checked the pressure at that time?

Edit;
I don't believe its a fuel issue, but thats just me trouble shooting from another city. :)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Dropped the gas tank and pulled the fuel pump out and found that the fuel pump assy was not snapped together on one side where it hinges together. Probably from a previous accident that dislodged it. The wires were then pulled tight and the connector was melted enough that the connection was intermittent until it was lost for good.

New pump assy going in today.

Also noticed one of the wires going to the tank harness has a chip in the insulation and there is corrosion coming out of it, so I will be fixing that too, must have been done on the assy line.
 

·
Lifetime Member
Joined
·
3,269 Posts
Looks like you got it going on now!
Thanks for posting the problem with an apparent solution, its little post like this that help others.
 

·
Registered
Joined
·
1 Posts
Car drove fine then quit. I have no fuel pressure. Took to be diagnosed. They told me fuel pump was bad cam sensor and leak in vacuum system. I bought new fuel pump installed it and car ran fine. Died later that day. Went and rented fuel pressure tester. Put on injector rail and i turn key on and it doesnt read nothing. I can hear the hum of fuel pump kicking on. I disconnected line under car and turned key on and gas came squirting out line. It wants to start but wont quite get there. I am lost. Please any help would be appreciated. 2007 pontaic g6 3.5l
 
1 - 6 of 6 Posts
Top