Pontiac G6 Forum banner

1 - 9 of 9 Posts

·
Banned
Joined
·
44 Posts
Discussion Starter #1
Well I'm not sure exactly what happened. I was out last night and listening to the stock XM system in the car, and it was working just fine. I shut the car off went inside to get something came back out, flipped on the radio and could only get FM1, FM2, and AM. It's like the option for the XM wasn't even there.

I'm confused!
 

·
Registered
Joined
·
279 Posts
XM band for GM radios currently uses a completely separate module from the radio head in dash. This module has an audio output feed into the stereo aux input on radio. These modules also communicate to each other over serial data.

Every time the vehicle starts up these 2 modules start communicating and the radio "relearns" that an XM module is in the vehicle (and thus when you press the band button it displays XM1, XM2 instead of just going between FM1, FM2 and AM.

So if this continues to happen my suggestion would be to consider that your XM receiver has somehow become "logic locked" - a term that I see service technicians use which I like :)

What you could try to do is pull the fuse which feeds the XM receiver and then reinsert it after 30 seconds or so and see if your XM receiver recovers. If it doesn't then you likely will need to go to dealer to have them troubleshoot it.

Your owner manual will show which fuse is for the XM. It is fuse block located in trunk on left side of vehicle (I believe it is fuse #16 as shown on label). Leave ignition off so that radio is off. Pull out the 7.5 Amp fuse (only one in there that size) and reinsert after 30 seconds. Then turn on vehicle and see if XM band is functional again.
 

·
Registered
Joined
·
9 Posts
Displaying ALL the XM info!!

How does one display the full artist name and complete song title on the
DIC ?. Is there a scroll function I can turn on?? I do not care about having the station name on all the time. Can you change the default display to show say the song or something different??

Thanks!
 

·
Registered
Joined
·
1 Posts
I have a 06 G6 GT. Chrismas eve, XM and remote system was working fine. On the 26th no XM and the remote FOB won't lock or unlock anything. So I looked at fuse #16 and it was blown.. So I changed the fuse with the car turmed off. About 10 minutes later I starteds the car and lo and behold still NO XM or remote functions. The replacement fuse also blew out. So I have an appointment next week at the dealer unless someone has an idea of what I did wrong. TNX
 
1 - 9 of 9 Posts
Top